Running rough ,,/,,,Short ?


The old and reliable.

User avatar

Golden Jubilee
Golden Jubilee

Posts: 654

Joined: Tue Dec 04, 2012 5:38 pm

Post Thu Oct 18, 2018 4:31 pm

Running rough ,,/,,,Short ?

So I have completed my prosess of elimination and still the problem persists . rough or no Idle under , acts like no gas , runs OK at higher rpm . replaced coil ,points , roter ,cap , and carborater . Its timed right and the mixture is probly set right , right enough anyway ,problem persists in any setting , runs a little better richer .
But here's the interesting thing I found , and had noticed a while back ..... when I press the starter button and crank it over it only starts after I let go of the starter button ..!?..I looked at the starter button by dropping it out of the dash and crosssed up the terminals with a screwdriver , same thing , will start after the screw driver is removed .Looked at the wiring and all looks OK , new harness from Rhode Island , 5000 miles ago . Am going to look at the starter this weekend , I am not any good with meters and testers , am going to try and polerize my voltage regulater and see if maybe that is it but ,,,,,,,any ideas ??

I will say that up to this point it has been running fine , never let me down , stalled in an intersection and seemed like it was having the gas problem , started after a while but ???

Golden Jubilee
Golden Jubilee

Posts: 4046

Joined: Thu Nov 29, 2012 9:28 pm

Location: Lyman, IA

Post Thu Oct 18, 2018 8:43 pm

Re: Running rough ,,/,,,Short ?

I wonder if you have the wrong coil or someone added resistance type wires? Only firing after releasing the button tells me the voltage is too low while cranking to get a good spark. There can be many causes, one is a 12 volt coil on a 6 volt system, another is resistance wires instead of copper core spark plug wires, still another is just plain bad wire (primary) in the harness. Lots of stuff to look at/check out.

Yard Art
Yard Art

Posts: 95

Joined: Thu Dec 07, 2017 3:58 pm

Post Fri Oct 19, 2018 3:17 pm

Re: Running rough ,,/,,,Short ?

keep us posted on this I am interested if this a wiring loom problem...I am close to ordering a complete harness for my 46 K-2 from Rhode island Wire company.
Thanks.

Yard Art
Yard Art

Posts: 91

Joined: Tue Apr 04, 2017 8:00 am

Post Fri Oct 19, 2018 7:40 pm

Re: Running rough ,,/,,,Short ?

My 2 cents, had the same symptoms and after much frustration found it was a bad condenser.
User avatar

Golden Jubilee
Golden Jubilee

Posts: 654

Joined: Tue Dec 04, 2012 5:38 pm

Post Sat Oct 20, 2018 8:37 am

Re: Running rough ,,/,,,Short ?

I'm pretty confident of the wiring harness . The only component I haven't replaced is the condenser . It seems like that when the starter is engaged it may be shorting out , to some extent ,,?
At one point while cranking , after I released the button the starter kept cranking . ,
There may be multiple issues .
User avatar

Golden Jubilee
Golden Jubilee

Posts: 654

Joined: Tue Dec 04, 2012 5:38 pm

Post Sat Oct 20, 2018 7:52 pm

Re: Running rough ,,/,,,Short ?

The CONDENSER was the problem ! When I was trying to sort it out I had tried checking the timing and the timing light was pretty dim , was hard to see the mark , now I could use it as a flashlite !
Thankyou !

Yard Art
Yard Art

Posts: 91

Joined: Tue Apr 04, 2017 8:00 am

Post Sat Oct 20, 2018 8:30 pm

Re: Running rough ,,/,,,Short ?

Glad to hear it's running, keep on truckin!

Return to K and KB

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software for PTF.